Функции проверки свойств и значений

Функции проверки свойств и значений ExcelФункции проверки свойств и значений в Excel.

Функции проверки свойств, чаще всего, используются как вспомогательные внутри логических функций.

Как следует из названия этой группы, они проверяют, соответствует ли значение в ячейке ожидаемому.

Синтаксис этих функций — простейший. Пишется через знак равно имя, и в скобках указывается ссылка на ячейку, которую необходимо проверить. Основную проблему у новичков вызывает вопрос, как их использовать. Между тем, во многих случаях, без них обойтись бывает сложно.

Для меня, как для бывшего HR-а, самое очевидное, где можно использовать функцию проверки текста, это табельный учет. Допустим, у нас имеется excel-форма ввода данных об отработанном времени, которую заполняют руководители. Если сотрудник работал, то руководитель ставит количество отработанных часов. Если сотрудник не работал, то руководитель ставит условное обозначение, обозначающий причину отсутствия сотрудника.

Вот, примерно такой табель у меня получился в свое время.

Нам, на основании этих данных, необходимо заполнить законодательно установленную форму табеля рабочего времени. Проблема заключается в том, что, в табеле необходимо указать и код рабочего времени, и количество отработанных часов. Как их развести?

Для этого используем две функции — ЕСЛИ (о ней в статье «Логические функции и сложные алгоритмы»), для создания условия, и ЕТЕКСТ, для критерия распределения данных по ячейкам. Логика формулы для отображения кодов будет такая:

Пишется эта формула так: =ЕСЛИ(ЕТЕКСТ(C3);C3;»Я»).

Для отображения только числовых значений лучше использовать функцию ЕЧИСЛО: =ЕСЛИ(ЕЧИСЛО(C3);C3;»»). Пустые кавычки вставят пустое значение, если проверяемая ячейка не будет числом.

Однако, для полноценного табельного учета этой формулы будет недостаточно. Кадровики знают, что работа в праздники должна сопровождаться кодом «РВ». Это тоже нужно закладывать в формулу, но, поскольку, здесь будут использоваться другие функции, пример разработки формы табельного учета мы рассмотрим в отдельной статье.

Иногда в формулах необходимо предусмотреть возможность появления ошибки. Например, если есть вероятность деления на 0. Поскольку делить на 0 нельзя, то Excel выдаст значение «#ДЕЛ/0! «. Если на эту ячейку ссылаются еще и другие формулы, то все расчеты выдадут информацию об ошибке, то есть никаких расчетов не будет.

В этом случае можно использовать формулу: =ЕСЛИ(ЕОШИБКА(A1/B1);0;A1/B1). Логика ее такова:

Пример использования функции ЕПУСТО описан у меня в статье «Оформление командировки в Excel«. Мы, с помощью нее, добились отображение пустой ячейке, если в ячейке, на которую ссылались, тоже не было никаких записей. В противном случае, ссылка на пустую ячейку выводила бы цифру 0.

Использование функций ЕЧЁТН и ЕНЕЧЁТ можно привести из области работы с номерами домов. Мы знаем, что, как правило, четные номера домов располагаются по одну сторону улицы, а нечетные — по другую. Допустим, у нас есть список, который необходимо рассортировать по сторонам А и Б.  В колонку А вносим четные номера, в колонку Б — нечетные.

Формулы, соответственно, будут такие:

А — =ЕСЛИ(ЕЧЁТН(C2);C2;»»);

Б — =ЕСЛИ(ЕНЕЧЁТ(C2);C2;»»).

На этом я заканчиваю цикл статей, посвященных начинающим любителям Excel.

Дальнейшие темы для начинающих буду развивать уже опираясь на запросы читателей этого сайта. Пишите мне в комментариях и предлагайте темы.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *