Как в кабинете

Подсчет уникальных значений в Excel

Unikalnie znachenie 1 6 способов создать список уникальных значений в Excel

В данной для нас статье я желаю поведать о способности сделать перечень уникальных значений в таблицах Excel. Эта возможность весьма нередко употребляется при работе с таблицами, потому что нередко возникает потребность с огромного массива данных избрать неповторимые данные, которые не повторяются. Это быть может необходимо для различных целей, и уже для вас решать каким методом и как произвести отбор подходящих для вас уникальных значений.

Перечень уникальных значений может быть сделать 6-ю методами:

  1. При помощи специальной функции;
  2. При помощи расширенного фильтра;
  3. При помощи формул;
  4. При помощи сводных таблиц;
  5. При помощи условного форматирования;
  6. При помощи способностей макроса.

Сделать перечень уникальных значений с помощью специальной функции

Это весьма обычный метод для хозяев Excel выше 2007 версии как произвести отбор уникальных значений. Для вас необходимо на вкладке «Данные», в разделе «Работа с данными», употреблять специальную команду «Удалить дубликаты».

В показавшемся диалоговом окне «Удалить дубликаты», вы выделяете те столбики, где нужно произвести отсев уникальных значений и нажимаете «Ок». В случае, когда в выделенном спектре располагается и заголовок таблицы, то поставьте галочку на пт «Мои данные содержат заглавия», что бы вы случаем не удалили данные.

Unikalnie znachenie 2 6 способов создать список уникальных значений в Excel

Сделать перечень уникальных значений с помощью расширенного фильтра

Это также не непростой метод произвести отбор уникальных значений в таблице. Употреблять этот инструмент может быть на вкладке «Данные», позже избрать «Фильтр», и в конце концов «Расширенный фильтр», этот путь подступает для Excel 2003, а вот обладатели наиболее молодых версий, от 2007 и выше стоит пройти по пути: «Данные» — «Сортировка и фильтр» — «Добавочно». Большой плюс этого метода в том, что вы сможете сделать новейший перечень уникальных значений в другом месте.

Интересно почитать:  Excel если больше числа и меньше числа то

Unikalnie znachenie 3 6 способов создать список уникальных значений в Excel

Unikalnie znachenie 4 6 способов создать список уникальных значений в Excel

Внимание!Если программка воспрещает для вас переносить отфильтрованные данные на иной лист, вы просто запустите «Расширенный фильтр» на том листе, куда для вас нужно перенести отобранные неповторимые значения.

Сделать перечень уникальных значений с помощью формул

Этот метод наиболее сложен, нежели те, что мы разглядывали ранее, но его преимущество в том, что он наиболее динамичен и работает на неизменной базе. В различных вариантах для вас будут необходимы различные формулы, вот и разглядим несколько вариантов и примеров.

Пример 1. Для вас необходимо пронумеровать, неповторимые, значение в перечне значений, для этого необходимо употреблять функцию ЕСЛИ в формуле последующего вида:

=ЕСЛИ(СЧЁТЕСЛИ(B$1:B2;B2)=1;МАКС(A$1:A1)+1;»»)

Сущность формулы в том, что она инспектирует сколько раз, текущее значение встречается в вашем спектре (начиная с начала), и если это значение равно 1, другими словами это 1-ое неповторимое значение, формула ставит поочередно ворачивающий номер по порядку.

Unikalnie znachenie 5 6 способов создать список уникальных значений в Excel

=ЕСЛИ(МАКС(A1:A100)<СТРОКА(1:1);»»;ВПР(СТРОКА(1:1); A1:B100;2))

Эта формула перебирает весь спектр сверху вниз по столбику с номерами и все позиции значений с номерами переносит в, другую таблицу.

Unikalnie znachenie 6 6 способов создать список уникальных значений в Excel

Видите ли, что тут была применена разметка формул массива, о этом свидетельствуют фигурные скобки, и таковой тип формул вводится в ячейку жарким сочетанием кнопок Ctrl+Shift+Enter. Опосля протяжки формулы, если вы увидите значение ошибки #ЧИСЛО, это свидетельствует о том, что неповторимые значения закончились. Для избегания данной для нас ошибки есть возможность поменять и усовершенствовать формулу, сделав ее последующего вида для Excel 2007 и выше:

В этом случае, если у вас и выходит ошибка #ЧИСЛО, то система будет ставить пустые ячейки.

Unikalnie znachenie 7 6 способов создать список уникальных значений в Excel

Сделать перечень уникальных значений с помощью сводных таблиц

Этот метод в неком роде необычный для отбора уникальных значений, но, тем не наименее, он действителен и готов для вас посодействовать. Для этого для вас необходимо:

  • для вас необходимо выделить один либо парочку столбцов в таблице, и выбираете вкладку «Вставка», группа «Таблица», иконка «Сводная таблица»;
  • в показавшемся диалоговом окне «Создание сводной таблицы» проводим перепроверку, верно ли указан спектр выделенных значений, ну либо устанавливаете иной источник данных;
  • последующим шагом вы указываете пространство, куда необходимо расположить, вашу сводную таблицу, вероятны два варианты: на новейший листок либо уже на имеющийся.
  • крайним шагом необходимо подтвердить создание сводной таблицы, нажав клавишу «Ок».

Далее уже сводная таблица отбирает все неповторимые значения в полном объеме либо уже по выставленным условиям.

Интересно почитать:  Эксель максимальное значение из диапазона

Unikalnie znachenie 8 6 способов создать список уникальных значений в Excel

Сделать перечень уникальных значений с помощью условного форматирования

Этот метод я тоже не буду причислять к суровому либо сложному. Для использования условного форматирования для отбора уникальных значений для вас необходимо перейти на вкладку «Основная», далее в группе «Стили» избрать клавишу меню «Условное форматирование» в предложенном перечне нам нужен пункт «Сделать правило». В открывшемся диалоговом окне «Создание правила форматирования» активируем пункт «Употреблять формулу для определения форматируемых ячеек» и в поле «Поменять описание правила» вводим нашу формулу-условие:

=ПОИСКПОЗ(D2;$D$2:$D$9;0)=СТРОКА(D2) -СТРОКА($D$1)

и выставляем формат подходящих нам уникальных значений при совпадении критерий, например, заливка красноватым цветом.

Ссылка на основную публикацию
Adblock
detector