Функция СЧЁТЕСЛИ в Excel

Это интегрированная функция в MS Excel. СЧЁТЕСЛИ в Excel употребляется для СЧЁТЕСЛИ количества ячеек, содержащих числа в данном спектре. Возвращает целое число. Это расширенная версия COUNT, интегрированной функции Excel, которая подсчитывает числовые значения, присутствующие в данном спектре ячеек.

Формула СЧЁТЕСЛИ в Excel

Формула СЧЁТЕСЛИ в Excel смотрится последующим образом:

Формула СЧЁТЕСЛИ в Excel

Формула СЧЁТЕСЛИ имеет два аргумента, один из которых является неотклонимым.

  • диапазон = Это неотклонимый параметр. Он представляет собой спектр значений, к которым будут применяться аспекты. Это быть может одно значение из перечня значений.
  • аспекты = Это очередной неотклонимый параметр, который представляет условие, которое будет применяться к значениям, представленным в спектре, обозначенном в качестве первого параметра. В итоге будут возвращены лишь значения, удовлетворяющие данным аспектам.

Возвращаемое значение формулы СЧЁТЕСЛИ в Excel — положительное число. Значение быть может нулевым либо ненулевым.

Как употреблять функцию СЧЁТЕСЛИ в Excel?

Обозначенная функция является функцией рабочего листа (WS). Как функцию WS, ее можно ввести как часть формулы в ячейку рабочего листа. Обратитесь к примерам, приведенным ниже, чтоб лучше осознать.

Функция СЧЁТЕСЛИ в листе Excel

Давайте поглядим на примеры, приведенные ниже. Любой пример обхватывает различные варианты использования, реализованные с внедрением this.

Пример # 1 — Подсчет значений с данным значением

Как показано в функции СЧЁТЕСЛИ в Excel, она применяется к спектру A2: A7. Условие тут — 33. Спектр содержит лишь одно такое число, которое удовлетворяет условию равенства 50. Как следует, итог, возвращаемый функцией СЧЁТЕСЛИ, равен единице, и то же самое видно в ячейке результата A8. См. Приведенный ниже скриншот для объясненного выше примера.

Примеры работы функций СЧЁТ, СЧИТАТЬПУСТОТЫ и СЧЁТЕСЛИ в Excel. Если счет

Функция СЧЕТЕСЛИ в Excel и примеры ее использования

Функция СЧЕТЕСЛИ заходит в группу статистических функций. Дозволяет отыскать число ячеек по определенному аспекту. Работает с числовыми и текстовыми значениями, датами.

Синтаксис и индивидуальности функции

Поначалу разглядим аргументы функции:

  • Спектр – группа значений для анализа и подсчета (неотклонимый).
  • Аспект – условие, по которому необходимо подсчитать ячейки (неотклонимый).

В спектре ячеек могут находиться текстовые, числовые значения, даты, массивы, ссылки на числа. Пустые ячейки функция игнорирует.

В качестве аспекта быть может ссылка, число, текстовая строчка, выражение. Функция СЧЕТЕСЛИ работает лишь с одним условием (по дефлоту). Но можно ее «вынудить» проанализировать 2 аспекта сразу.

Интересно почитать:  Вычитание функция в excel

Советы для правильной работы функции:

  • Если функция СЧЕТЕСЛИ ссылается на спектр в иной книжке, то нужно, чтоб эта книжка была открыта.
  • Аргумент «Аспект» необходимо заключать в кавычки (не считая ссылок).
  • Функция не учитывает регистр текстовых значений.
  • При формулировании условия подсчета можно употреблять подстановочные знаки. «?» — хоть какой знак. «*» — неважно какая последовательность знаков. Чтоб формула находила конкретно эти знаки, ставим перед ними символ тильды (

Функция СЧЕТЕСЛИ в Excel: примеры

Посчитаем числовые значения в одном спектре. Условие подсчета – один аспект.

У нас есть таковая таблица:

Посчитаем количество ячеек с числами больше 100. Формула: =СЧЁТЕСЛИ(B1:B11;»>100″). Спектр – В1:В11. Аспект подсчета – «>100». Итог:

Если условие подсчета внести в отдельную ячейку, можно в качестве аспекта употреблять ссылку:

Посчитаем текстовые значения в одном спектре. Условие поиска – один аспект.

Формула: =СЧЁТЕСЛИ(A1:A11;»табуреты»). Либо:

Во 2-м случае в качестве аспекта употребляли ссылку на ячейку.

Формула с применением знака подстановки: =СЧЁТЕСЛИ(A1:A11;»таб*»).

Для расчета количества значений, оканчивающихся на «и», в которых содержится хоть какое число символов: =СЧЁТЕСЛИ(A1:A11;»*и»). Получаем:

Формула посчитала «кровати» и «банкетки».

Используем в функции СЧЕТЕСЛИ условие поиска «не равно».

Формула: =СЧЁТЕСЛИ(A1:A11;»»&»стулья»). Оператор «» значит «не равно». Символ амперсанда (&) соединяет воединыжды данный оператор и значение «стулья».

При применении ссылки формула будет смотреться так:

Нередко требуется делать функцию СЧЕТЕСЛИ в Excel по двум аспектам. Таковым методом можно значительно расширить ее способности. Разглядим особые случаи внедрения СЧЕТЕСЛИ в Excel и примеры с 2-мя критериями.

  1. Посчитаем, сколько ячеек содержат текст «столы» и «стулья». Формула: =СЧЁТЕСЛИ(A1:A11;»столы»)+СЧЁТЕСЛИ(A1:A11;»стулья»). Для указания нескольких критерий употребляется несколько выражений СЧЕТЕСЛИ. Они объединены меж собой оператором «+».
  2. Условия – ссылки на ячейки. Формула: =СЧЁТЕСЛИ(A1:A11;A1)+СЧЁТЕСЛИ(A1:A11;A2). Текст «столы» функция отыскивает в ячейке А1. Текст «стулья» — на базе аспекта в ячейке А2.
  3. Посчитаем число ячеек в спектре В1:В11 со значением огромным либо равным 100 и наименьшим либо равным 200. Формула: =СЧЁТЕСЛИ(B1:B11;»>=100″)-СЧЁТЕСЛИ(B1:B11;»>200″).
  4. Применим в формуле СЧЕТЕСЛИ несколько диапазонов. Это может быть, если спектры являются смежными. Формула: =СЧЁТЕСЛИ(A1:B11;»>=100″)-СЧЁТЕСЛИ(A1:B11;»>200″). Отыскивает значения по двум аспектам сходу в 2-ух столбцах. Если спектры несмежные, то применяется функция СЧЕТЕСЛИМН.
  5. Когда в качестве аспекта указывается ссылка на спектр ячеек с критериями, функция возвращает массив. Для ввода формулы необходимо выделить такое количество ячеек, как в спектре с аспектами. Опосля введения аргументов надавить сразу сочетание кнопок Shift + Ctrl + Enter. Excel распознает формулу массива.

СЧЕТЕСЛИ с 2-мя критериями в Excel весьма нередко употребляется для автоматической и действенной работы с данными. Потому продвинутому юзеру настоятельно рекомендуется пристально изучить все приведенные выше примеры.

ПРОМЕЖУТОЧНЫЕ.ИТОГИ и СЧЕТЕСЛИ

Посчитаем количество реализованных продуктов по группам.

  1. Поначалу отсортируем таблицу так, чтоб однообразные значения оказались рядом.
  2. 1-ый аргумент формулы «ПРОМЕЖУТОЧНЫЕ.ИТОГИ» — «Номер функции». Это числа от 1 до 11, указывающие статистическую функцию для расчета промежного результата. Подсчет количества ячеек осуществляется под цифрой «2» (функция «СЧЕТ»).

Скачать примеры функции СЧЕТЕСЛИ в Excel

Формула отыскала количество значений для группы «Стулья». При большенном числе строк (больше тыщи) схожее сочетание функций может оказаться полезным.

СЧЁТЕСЛИ (функция СЧЁТЕСЛИ) — Служба саппорта Office

При помощи статистической функции СЧЁТЕСЛИ можно подсчитать количество ячеек, отвечающих определенному условию (к примеру, число клиентов в перечне из определенного городка).

Самая обычная функция СЧЁТЕСЛИ значит последующее:

Группа ячеек, для которых необходимо выполнить подсчет. Спектр может содержать числа, массивы, именованный спектр либо ссылки на числа. Пустые и текстовые значения игнорируются.

Узнайте, как выбирать спектры на листе.

Число, выражение, ссылка на ячейку либо текстовая строчка, которая описывает, какие ячейки необходимо подсчитать.

К примеру, аспект быть может выражен как 32, «>32», В4, «яблоки» либо «32».

В функции СЧЁТЕСЛИ употребляется лишь один аспект. Чтоб провести подсчет по нескольким условиям, воспользуйтесь функцией СЧЁТЕСЛИМН.

Примеры

Чтоб употреблять эти примеры в Excel, скопируйте данные из приведенной ниже таблицы и вставьте их на новейший лист в ячейку A1.

Excel works!

Функция СУММЕСЛИ. 1-ый из 3-х китов Excel, можно сказать. Начинаю обзор основных инструментов возлюбленной нами программки от Microsoft. Сначала желаю поведать о моей нередко применяемой функции («формуле»): это функция СУММЕСЛИ. Если Вы не представляете, что же все-таки это такое, и как это употреблять — я для вас завидую! Для меня она была реальным открытием в свое время.

Для вас приходилось суммировать данные по сотрудникам либо клиентам из большенный таблицы, выбирать сколько выручки было по той либо другой номенклатуре? Вы фильтровали по фамилиям/позициям, а потом вносили числа руками в отдельные ячейки? Быть может считали на калькуляторе? А если строк больше тыщи? Как посчитать стремительно итог для каждой из строк?

Вот здесь и понадобится СУММЕСЛИ!

Задача1. Существует статистика по товарам, городкам и по тому, какие характеристики были достигнуты по сиим позициям. Нужно высчитать «на какую сумму продано номенклатуры Товар1?»

Функция СУММЕСЛИ в Excel

Как работает Функция СУММЕСЛИ в Excel? Подсчет суммы по значению

До этого чем приступить к решению 1ой задачки, разберем из что состоит функция СУММЕСЛИ:

  • Спектр. Спектр, в котором содержатся условия поиска. Заполнять непременно. Для 1ой задачки столбец Продукт.
  • Аспект. Можно заполнить числом (85), выражением («>85»), ссылкой на ячейку (B1), функцией (СЕГОДНЯ()). Описывает условие, по которому суммируются (!). Все текстовые условия заключаются в кавычки («) «>85». Заполнять непременно. Для 1ой задачки столбец =Товар1
  • Диапазон_суммирования. Ячейки, для суммирования, если они различаются от ячеек в Спектре. Для 1ой задачки столбец Выручка.

Итак запишем формулу, за ранее занеся аргумент условия в ячейку F3

Функция СУММЕСЛИ в Excel

Не забудьте проверить 😉 Посчиталось? Правильно? Непревзойденно!

Как работает функция СУММЕСЛИМН в Excel? Подсчет суммы по значениям

Задача2. Нужно высчитать: «на какую сумму продано номенклатуры Товар3 в городке Казань?»

Т.е. отбор нужно выполнить по двум характеристикам. Для этого употребляется функция СУММЕСЛИ для нескольких критерий — СУММЕСЛИМН, где незначительно меняется порядок записи и количество аргументов — сначала пишем из какого столбца суммируем (в примере C:C), а потом уже условия.

Функция СУММЕСЛИ в Excel

Если вы желаете, чтоб функция смотрелась как на последующей картинке, т.е. имела прекрасные спектры, что дозволит комфортно употреблять их по всей книжке и не употреблять $ для закрепления ссылок, читайте статью Как создать прекрасные спектры .

Функция СУММЕСЛИ в Excel

Как работает функция СЧЕТЕСЛИ в Excel? Подсчет количества значений

Также для подсчета количества повторений той либо другой позиции используйте функции СЧЁТЕСЛИ (СЧЁТЕСЛИМН)

Задача3. Нужно высчитать: «сколько раз повторялось значение=»Самара» в столбце Город

Ссылка на основную публикацию
Adblock
detector