В excel какая функция - Учим Эксель

Проверка на четность excel

Пусть имеется начальная таблица с размерами продаж продуктов по кварталам.

Нам требуется показать лишь четные либо нечетные строчки.

Примечание: О выделении нечетных строк Условным форматированием читайте в статье о Чрезстрочном выделении.

Автофильтр

Это можно просто создать при помощи Автофильтра в столбце F. Для этого в ячейку F8 введите формулу =ЕЧЁТН(СТРОКА()-СТРОКА($F$7)) и скопируйте ее вниз. Формула для четных строк таблицы (не листа!) возвращает ИСТИНА.

Сейчас при помощи Автофильтра можно избрать или четные или нечетные строчки.

Формулы

Выведем четные и нечетные строчки при помощи формул.

При помощи формулы =ИНДЕКС(A$8:A$17;(СТРОКА()-СТРОКА($A$21))*2) можно отобрать лишь четные строчки из начальной таблицы.

При помощи формулы =ИНДЕКС(A$8:A$17;(СТРОКА()-СТРОКА($A$30))*2-1) можно отобрать лишь нечетные строчки.

В данной статье описаны синтаксис формулы и внедрение функции ЕЧЁТН в Microsoft Excel.

Описание

Возвращает значение ИСТИНА, если число четное, и значение ЛОЖЬ, если число нечетное.

Синтаксис

Аргументы функции ЕЧЁТН описаны ниже.

Число Неотклонимый. Проверяемое значение. Если число не является целым, оно усекается.

Замечания

Если значение аргумента "число" не является числом, функция ЕЧЁТН возвращает значение ошибки #ЗНАЧ!.

Пример

Скопируйте эталон данных из последующей таблицы и вставьте их в ячейку A1 новейшего листа Excel. Чтоб показать результаты формул, выделите их и нажмите кнопку F2, а потом — кнопку ВВОД. По мере необходимости измените ширину столбцов, чтоб созидать все данные.

Инспектирует, является ли число -1 четным

Инспектирует, является ли число 2,5 четным. Дробная часть (0,5) усекается, потому проверяется число 2.

Инспектирует, является ли число 5 четным.

Нуль (0) считается четным.

Инспектирует дату в ячейке A6. Десятичное представление даты 23.12.2011 — 40900.

Get expert help now

Don’t have time to figure this out? Our expert partners at Excelchat can do it for you, 24/7.

Интересно почитать:  Функция транспонирования в excel

Когда необходимо приготовить различного рода отчеты, время от времени возникает потребность выделить все парные и непарные числа различными цветами. Для решения данной задачки более оптимальным методом является условное форматирование.

Как отыскать четные числа в Excel

Набор четных и нечетных чисел, которые следует автоматом выделить различными цветами:

Допустим парные числа нам необходимо выделит зеленоватым цветом, а непарные – голубым.

  1. Выделите спектр ячеек A1:A8 и изберите инструмент: «ГЛАВНАЯ»-«Стили»-«Условное форматирование»-«Сделать правило».
  2. Ниже изберите: «Применять формулу для определения форматируемых ячеек».
  3. Чтоб отыскать четное число в Excel ниже введите формулу: =ОСТАТ(A1;2)=0 и нажмите на клавишу «Формат», чтоб задать зеленоватый цвет заливки ячеек. И нажмите ОК на всех открытых окнах.
  4. Чтоб додать 2-ое условие, не снимая выделения с спектра A1:A8, опять избираем инструмент: «ГЛАВНАЯ»-«Стили»-«Условное форматирование»-«Сделать правило»-«Применять формулу для определения форматируемых ячеек».
  5. В поле ввода введите формулу: =ОСТАТ(A1;2)<>0 и нажмите на клавишу «Формат», чтоб задать голубий цвет заливки ячеек. И нажмите ОК на всех открытых окнах.
  6. К одному и тому же спектру обязано быть использовано 2 правила условного форматирования. Чтоб проверить изберите инструмент: «ГЛАВНАЯ»-«Стили»-«Условное форматирование»-«Управление правилами»

Две формулы различаются лишь операторами сопоставления перед значением 0. Закройте окно диспетчера правил нажав на клавишу ОК.

В итоге у нас ячейки, которые содержат непарное число имеют голубий цвет заливки, а ячейки с парными числами – зеленоватый.

Функция ОСТАТ в Excel для поиска четных и нечетных чисел

Функция =ОСТАТ() возвращает остаток от деления первого аргумента на 2-ой. В первом аргументе мы указываем относительную ссылку, потому что данные берутся из каждой ячейки выделенного спектра. В первом правиле условного форматирования мы указываем оператор «равно» =0. Потому что хоть какое парное число, разделенное на 2 (2-ой оператор) имеет остаток от деления 0. Если в ячейке находится парное число формула возвращает значение ИСТИНА и присваивается соответственный формат. В формуле второго правила мы используем оператор «неравно» <>0. Таковым образом выделяем голубым цветом нечетные числа в Excel. Другими словами механизм работы второго правила действует назад пропорционально первому правилу.

Ссылка на основную публикацию
Adblock
detector