Excel если значение ячейки то значение - Учим Эксель

Функция ЕСЛИ в Excel. Как употреблять

Функция ЕСЛИ в Excel. Как употреблять?

Функция ЕСЛИ в Excel – это хороший инструмент для проверки критерий на ИСТИНУ либо ЛОЖЬ. Если значения ваших расчетов равны данным характеристикам функции как ИСТИНА, то она возвращает одно значение, если ЛОЖЬ, то другое.

Что возвращает функция

Данное вами значение при выполнении 2-ух критерий ИСТИНА либо ЛОЖЬ.

Синтаксис

=IF(logical_test, [value_if_true], [value_if_false]) – британская версия

=ЕСЛИ(лог_выражение; [значение_если_истина]; [значение_если_ложь]) – российская версия

Аргументы функции

  • logical_test (лог_выражение) – это условие, которое вы желаете протестировать. Этот аргумент функции должен быть логичным и определяемым как ЛОЖЬ либо ИСТИНА. Аргументом быть может как статичное значение, так и итог функции, вычисления;
  • [value_if_true] ([значение_если_истина]) – (не непременно) – это то значение, которое возвращает функция. Оно будет отображено в случае, если значение которое вы тестируете соответствует условию ИСТИНА;
  • [value_if_false] ([значение_если_ложь]) – (не непременно) – это то значение, которое возвращает функция. Оно будет отображено в случае, если условие, которое вы тестируете соответствует условию ЛОЖЬ.

Доборная информация

IF-EXCEL-01

  • В функции ЕСЛИ быть может протестировано 64 критерий за один раз;
  • Если какой-нибудь из аргументов функции является массивом – оценивается любой элемент массива;
  • Если вы не укажете условие аргумента FALSE (ЛОЖЬ) value_if_false (значение_если_ложь) в функции, т.е. опосля аргумента value_if_true (значение_если_истина) есть лишь запятая (точка с запятой), функция возвратит значение “0”, если итог вычисления функции будет равен FALSE (ЛОЖЬ).
    На примере ниже, формула =IF(A1> 20,”Разрешить”) либо =ЕСЛИ(A1>20;”Разрешить”) , где value_if_false (значение_если_ложь) не обозначено, но аргумент value_if_true (значение_если_истина) как и раньше следует через запятую. Функция возвратит “0” каждый раз, когда проверяемое условие не будет соответствовать условиям TRUE (ИСТИНА).

    |

  • Если вы не укажете условие аргумента TRUE(ИСТИНА) (value_if_true (значение_если_истина)) в функции, т.е. условие обозначено лишь для аргумента value_if_false (значение_если_ложь), то формула возвратит значение “0”, если итог вычисления функции будет равен TRUE (ИСТИНА);
    На примере ниже формула равна = IF (A1>20;«Отказать») либо =ЕСЛИ(A1>20;”Отказать”) , где аргумент value_if_true (значение_если_истина) не указан, формула будет возвращать “0” каждый раз, когда условие соответствует TRUE (ИСТИНА).

IF EXCEL - 02

Функция Если в Excel примеры с несколькими критериями

Пример 1. Проверяем обычное числовое условие при помощи функции IF (ЕСЛИ)

При использовании функции ЕСЛИ в Excel, вы сможете употреблять разные операторы для проверки состояния. Вот перечень операторов, которые вы сможете употреблять:

IF-EXCEL-03

Ниже приведен обычный пример использования функции при расчете оценок студентов. Если сумма баллов больше либо равна “35”, то формула возвращает “Сдал”, по другому ворачивается “Не сдал”.

Excel-IF-04

Пример 2. Внедрение вложенной функции IF (ЕСЛИ) для проверки условия выражения

Функция может принимать до 64 критерий сразу. Невзирая на то, что создавать длинноватые вложенные функции нецелесообразно, то в редчайших вариантах вы сможете сделать формулу, которая огромное количество критерий поочередно.

В приведенном ниже примере мы проверяем два условия.

  • 1-ое условие инспектирует, сумму баллов не меньше ли она чем 35 баллов. Если это ИСТИНА, то функция возвратит “Не сдал”;
  • В случае, если 1-ое условие – ЛОЖЬ, и сумма баллов больше 35, то функция инспектирует 2-ое условие. В случае если сумма баллов больше либо равна 75. Если это правда, то функция возвращает значение “Непревзойденно”, в остальных вариантах функция возвращает “Сдал”.

Excel-If-06

Пример 3. Вычисляем сумму комиссии с продаж при помощи функции IF (ЕСЛИ) в Excel

Функция дозволяет делать вычисления с числами. Неплохой пример использования – расчет комиссии продаж для торгового представителя.

В приведенном ниже примере, торговый представитель по продажам:

  • не получает комиссионных, если размер продаж меньше 50 тыс;
  • получает комиссию в размере 2%, если реализации меж 50-100 тыс
  • получает 4% комиссионных, если размер продаж превосходит 100 тыс.

Высчитать размер комиссионных для торгового агента можно по последующей формуле:

=IF(B2<50,0,IF(B2<100,B2*2%,B2*4%)) – британская версия

=ЕСЛИ(B2<50;0;ЕСЛИ(B2<100;B2*2%;B2*4%)) – российская версия

Excel-IF-07

В формуле, использованной в примере выше, вычисление суммы комиссионных производится в самой функции ЕСЛИ . Если размер продаж находится меж 50-100K, то формула возвращает B2 * 2%, что составляет 2% комиссии зависимо от размера реализации.

Пример 4. Используем логические операторы (AND/OR) (И/ИЛИ) в функции IF (ЕСЛИ) в Excel

Вы сможете употреблять логические операторы (AND/OR) (И/ИЛИ) снутри функции для одновременного тестирования нескольких критерий.

К примеру, представим, что вы должны избрать студентов для стипендий, основываясь на оценках и посещаемости. В приведенном ниже примере учащийся имеет право на роль лишь в этом случае, если он набрал наиболее 80 баллов и имеет посещаемость наиболее 80%.

Excel-If-09

Вы сможете употреблять функцию AND (И) вкупе с функцией IF (ЕСЛИ) , чтоб поначалу проверить, производятся ли оба эти условия либо нет. Если условия соблюдены, функция возвращает “Имеет право”, в неприятном случае она возвращает “Не имеет право”.

Формула для этого расчета:

Excel-IF-10

Пример 5. Преобразуем ошибки в значения “0” при помощи функции IF (ЕСЛИ)

При помощи данной функции вы также сможете убирать ячейки содержащие ошибки. Вы сможете конвертировать значения ошибок в пробелы либо нули либо хоть какое другое значение.

Формула для преобразования ошибок в ячейках последующая:

=IF(ISERROR(A1),0,A1) – британская версия

=ЕСЛИ(ЕОШИБКА(A1);0;A1) – российская версия

Формула возвращает “0”, в случае если в ячейке есть ошибка, по другому она возвращает значение ячейки.

ПРИМЕЧАНИЕ. Если вы используете Excel 2007 либо версии опосля него, вы также сможете употреблять функцию IFERROR для этого.

Буквально так же вы сможете обрабатывать пустые ячейки. В случае пустых ячеек используйте функцию ISBLANK, на примере ниже:

=IF(ISBLANK(A1),0,A1) – британская версия

=ЕСЛИ(ЕПУСТО(A1);0;A1) – российская версия

EXCEL-IF-11

Еще более нужных приемов в работе с функциями и перечнями данных в Excel вы узнаете в практическом курсе “От новенького до мастера Excel“. Успей зарегистрироваться по ссылке!

Функция ЕСЛИ в EXCEL

Функция ЕСЛИ() относится к более нередко применяемым функциям. Потому разглядим ее тщательно.

Синтаксис функции

ЕСЛИ(лог_выражение;значение_если_истина;[значение_если_ложь])

Функция имеет 3 аргумента.

Лог_выражение — хоть какое значение либо выражение, принимающее значения ИСТИНА либо ЛОЖЬ. К примеру, выражение A1>100. Если в ячейке А1 содержится значение 102, то выражение A1>100 возвратит ИСТИНА, т.к. 102>100. Если в ячейке А1 содержится значение 88, то выражение возвратит ЛОЖЬ, т.к. неравенство 88>100 ошибочно. На сто процентов формула может смотреться так =ЕСЛИ(A1>100;»Бюджет проекта превышен»;»ОК!») Если в ячейке A1 содержится значение большее 100, то формула возвратит текстовое значение Бюджет проекта превышен, а если меньше 100 либо равное 100, то будет выведено ОК!

Остальных значений не считая ИСТИНА либо ЛОЖЬ логическое выражение возвратить не может. Хоть какое число не считая 0 в первом аргументе будет преобразовано в ИСТИНА, ноль — в ЛОЖЬ. Если неверно будет обозначено текстовое значение, то функция возвратит ошибку #ЗНАЧ!.

Примечание : Ошибка #ЗНАЧ! быть может также из-за ошибок в выражениях обозначенных во 2-м и третье аргументе.

2-ой аргумент — Значение_если_истина и 3-ий аргумент значение_если_ложь

Как было показано выше, если логическое выражение (1-ый аргумент функции) воспринимает значение ИСТИНА, то функция возвращает значение из второго аргумента значение_если_истина. Соответственно, если логическое выражение воспринимает значение ЛОЖЬ, то функция возвращает значение из третьего аргумента значение_если_ложь .

2-ой и 3-ий аргумент могут быть хоть каким значением (число либо текст) либо являться выражением (формулой с функциями). К примеру формула =ЕСЛИ(A1>100;0;А1*1%) дозволяет вычислять премию для проектов, в каких не было превышения бюджета (>100). Если бюджет превышен (в А1 введено значение 200 либо хоть какое другое наиболее 100), то формула возвратит 0, если в А1 введено значение наименее 100, то будет вычислено значение премии А1*1% (т.е. если в А1 число 90, то формула возвратит 0,9).

Если в качестве второго и третьего аргументов введено выражение, то оно может содержать и функции, к примеру: =ЕСЛИ(A1>100;СУММ(B1:B10);СУММ(C1:C10)) Т.е. если в ячейке A1 содержится значение >100, то суммирование ведется по столбцу B , а если меньше либо равно 100, то по столбцу С . Не запамятовывайте, что при значении А1 = 100 в этом случае будет срабатывать выражение из аргумента значение_если_ложь.

Аргумент значение_если_ложь можно опустить (не вводить), тогда при значении логического выражения =ЛОЖЬ будет выведено ЛОЖЬ. К примеру, если в А1 содержится 600, то формула =ЕСЛИ(A1>=1000;»Больше либо равно 1000″) возвратит просто ЛОЖЬ. Понятно, что при значении логического выражения =ИСТИНА будет выведено «Больше либо равно 1000», т.е. 2-ой аргумент функции ЕСЛИ() — Значение_если_истина.

Вложенные ЕСЛИ (несколько критерий)

Для построения наиболее сложных проверок в одной формуле можно употреблять несколько функций ЕСЛИ(). Для этого в качестве значений аргументов значение_если_истина и значение_если_ложь введите очередное условие с функцией ЕСЛИ(). К примеру, для проверки в которой спектр попадает значение из ячейки А8 запишите формулу

  • Если значение из ячейки А8 наименее 5, то будет выведено 1
  • Если значение из ячейки А8 наиболее 10, то будет выведено 3
  • Если значение из ячейки А8 меж 5 и 10 (включая 5 и 8), то будет выведено 2

Примечание : В версии EXCEL 2007 можно употреблять до 64 вложенных друг в друга функций ЕСЛИ(). Но, пожалуйста, не делайте так. Таковой подход чреват ошибками.

Примечание : Формулу =ЕСЛИ(A8 10;3;2)) можно переписать как =ЕСЛИ(A8>=5;ЕСЛИ(A8>10;3;2);1) либо ЕСЛИ(A8>=5;ЕСЛИ(A8>10;3;2);1)

либо наиболее непростой вариант =ЕСЛИ(A8

Формула =ЕСЛИ(A8 10;3;2)) работает последующим образом: поначалу рассчитывается логическое выражение A8 =5, то EXCEL перебегает к вычислению выражения ЕСЛИ(A8>10;3;2). Снова поначалу рассчитывается логическое выражение A8>10. Если оно поистине, то выводится 3, вычисления завершены. Если оно неверно, то выводится 2, вычисления завершены.

Чтоб хорошо написать формулу с вложенными ЕСЛИ() следуйте последующим обычным правилам:

1) Обусловьтесь с спектрами:

1.1) они не должны пересекаться. В примере выше — 3 спектра и значение из А8 гарантированно попадет лишь в один из их. Было бы ошибкой написать формулу типа =ЕСЛИ(A8 10;3;ЕСЛИ(A8 10;3;2)) на интересует вся числовая ось от минус бесконечности до +бесконечности. И все 3 спектра вполне покрывают эту область.

1.3.) Не забудьте ставить символ равно, чтоб при значениях А8 совпадающих с границами интервалов не было некорректных вычислений. К примеру, если в формуле =ЕСЛИ(A8>=5;ЕСЛИ(A8>10;3;2);1) запамятовать указать символ = в логическом выражении A8>=5, то при А8=5 формула =ЕСЛИ(A8>5;ЕСЛИ(A8>10;3;2);1) возвратит 1, тогда как начальная формула возвратит 2.

Примечание: В вышеперечисленных вариантах логические выражения рассчитываются на основании одной переменной А8. Время от времени необходимо выдумывать формулы с ЕСЛИ(), зависящие от 2-х и наиболее ячеек: =ЕСЛИ(B8>=5;ЕСЛИ(A8>10;3;2);1). Это еще труднее, но, естественно, может быть. Следуйте правилам 1.1)-1.3) и смотрите за спектрами. Еще труднее, если обе переменных являются зависимыми, т.е. к примеру B8 рассчитывается на основании А8. Написание таковых формул просит предельной аккуратности и впрямую соединено с правильностью формулирования самой задачки (может быть вы не обмыслили до конца как употреблять такую сложную зависимость). Советую по способности разбить вычисления на 2 либо наиболее формулы, чтоб проще надзирать итог вычисления.

2) Верно записывайте логические выражения. К примеру, условие 5 10;3;2)) в строке формул можно записать как

Для этого поставьте курсор перед вторым ЕСЛИ(), нажмите и удерживайте кнопку ALT, нажмите ENTER.

4) для отладки вложенных ЕСЛИ заместо настоящих вычислений (V8*10%-37500) используйте обыкновенные значения — последовательности 1; 2; 3 . Это покажет какой блок вложенных ЕСЛИ() срабатывает.

5) В ряде всевозможных случаев от вложенных ЕСЛИ можно отрешиться. Разглядим пример определения размера проекта от его бюджета

=ЕСЛИ(A1>=100;»Весьма большой проект»;
ЕСЛИ(A1>=90;»Большой проект»;
ЕСЛИ(A1>=50;»Средний проект»;»Малый проект «)))

Вышеуказанную формулу можно усложнять и далее, но есть остальные подходы. Ниже приведено 2 эквивалентные формулы:

Для функции ВПР() нужно сделать в спектре A3:B6 таблицу значений:

Формула =ПРОСМОТР(A1;<0;50;90;100>;<"Малый проект";"Средний проект";"Крупный проект";"Очень крупный проект">) смотрится особенно, но на самом деле 2-ой аргумент <0;50;90;100>, как и 3-ий аргумент <"Малый проект";"Средний проект";"Крупный проект";"Очень крупный проект">это запись содержимого 4-х ячеек. Заместо <0;50;90;100>можно записать ссылку на спектр ячеек, содержащих 4 значения 0;50;90;100. Круглые скобки необходимы, чтоб сказать, что в функцию передается не одно значение, а целый массив.

Еще пример. Пусть требуется вывести различный текст (к примеру » 0″) в случае наличия в ячейке А1 отрицательного значения, положительного значения либо 0. Это можно создать без вложенных ЕСЛИ():

Примечание : -1E+307 — это самое малюсенькое отрицательное число в EXCEL, 1E-307 — это самое малюсенькое положительное число. Таковым образом задается 3 спектра: от минус бесконечности до 0 (0 не включая); 0 (спектр состоит лишь из 1-го значения 0); от 0 до +бесконечности (0 не включая).

2-ой массив можно поменять ссылкой на спектр, к примеру для того чтоб вывести итог вычисления формул:

Спектр A27:A29 должен, понятно, содержать формулы (см. файл примера).

Опущен 3-ий аргумент [значение_если_ложь]

3-ий аргумент функции не обязателен. Если логическое условие не выполнено, т.е. ЛОЖЬ, а 3-ий аргумент функции не указан, то функция возвратит также значение ЛОЖЬ. К примеру:

Если в ячейке A1 содержится значение 1, то вышеуказанная формула возвратит значение ЛОЖЬ.

Сложные логические выражения

В аргументе Лог_выражение можно употреблять как обыкновенные сопоставления типа F1>10, так и наиболее сложные конструкции на базе функций И(), ИЛИ(), НЕ() и их композиций.

Основное правило — логические функции и их композиции возвращают лишь одно из 2х логических значений: ЛОЖЬ либо ИСТИНА.

Приведем несколько нужных примеров.

Формула =ЕСЛИ(ИЛИ(A1;A2);0;2) инспектирует одновременность равенства значений А1 и А2 нулю. Если оба значения равны 0, то формула возвратит 2. Во всех остальных вариантах будет возвращен 0. А1 и А2 не должны быть пустыми ячейками.

Формула =ЕСЛИ(ИЛИ(A1=0;A2=0);0;2) инспектирует равенство 0 хотя бы 1-го значения из А1 и А2.

Формула =ЕСЛИ(НЕ(A1>0);1;2) эквивалентна формуле =ЕСЛИ(A1 10″) . Аналогичный итог (23) можно получить при помощи формулы массива =СУММ(ЕСЛИ(A6:A11>10;A6:A11)) (для ввода формулы в ячейку заместо ENTER необходимо надавить CTRL+SHIFT+ENTER )

Сейчас подсчитаем количество вхождений чисел больше 10 в спектре ячеек A6:A11 =СЧЁТЕСЛИ(A6:A11;»>10″) . Аналогичный итог (2) можно получить при помощи формулы массива =СЧЁТ(ЕСЛИ(A6:A11>10;A6:A11))

Сейчас, когда принцип понятен, при помощи функции ЕСЛИ() можно конструировать и остальные формулы с критериями. К примеру, нахождение малого значения посреди чисел больше 10: =МИН(ЕСЛИ(A6:A11>10;A6:A11))

Функция ЕСЛИ в Excel

Изучим функцию ЕСЛИ в Excel, которая дозволяет зависимо от выполнения условия возвращать различные значения, тщательно разберем примеры с одним и несколькими критериями.

Приветствую всех, дорогие читатели блога TutorExcel.Ru!

Сейчас предлагаю побеседовать о одной из базисных функций в Excel, без которой довольно трудно представить работу с любым файлом в Excel, поэтому что проверка каких-то критерий употребляется фактически каждым аналитиком, экономистом и в принципе хоть каким юзером программки.

Пойдет речь про функцию ЕСЛИ в Excel.

По сути сама функция довольно обычная, но потому что диапазон ее внедрения довольно широкой, то предлагаю разобрать сходу несколько примеров. Проверим как функция работает для 1-го условия, поглядим работу ЕСЛИ на примерах с несколькими критериями, также добавим остальные логические функции в Excel, которые могут быть полезны в композиции с данной функцией.

Функция ЕСЛИ в Excel. Синтаксис

Как и постоянно, исследование хоть какой функции давайте начнем с самого базисного — с синтаксиса функции ЕСЛИ (IF в британской версии):

ЕСЛИ (лог_выражение; значение_если_истина; значение_если_ложь)

Инспектирует, производится ли условие, и возвращает одно значение, если оно производится, и другое значение, если нет.

Функция содержит 3 аргумента: 1-ое — логическое выражение (обозначим буковкой А), 2-ое — значение если правда (примем как буковку B) и третье — значение если ересь (C).

По смыслу функция инспектирует логическое выражение A (обычно сюда прописывают условие проверки, к примеру, что одно число больше другого X>Y), если оно поистине, т.е. A выполнено, то функция возвращает одно значение (B), если же выражение неверно, т.е. A не выполнено, то возвращает уже другое (C). Если словестно не до конца понятно, то есть вот таковая приятная схема:

Принцип работы функции ЕСЛИ в Excel

Таковым образом, 1-ый аргумент функции ЕСЛИ — логическое условие, 2-ой аргумент — значение если условие поистине, 3-ий аргумент — если нет.

С синтаксисом функции разобрались, самое время перебегать к примерам.

Давайте разглядим маленькую таблицу с продажами по менеджерам и будем определять соответствие разным условиям. В первых 2-ух строках я добавочно прописал численные условия, чтоб в предстоящем при работе с формулами употреблять не абсолютные значения, а ссылки на ячейки для удобства конфигурации данных:

Исходная таблица с данными

Формула ЕСЛИ с одним условием

Разглядим пример — определим всех служащих, по которым выручка составила наиболее 50 тыс. руб. Если условие будет производиться, то будем возвращать текстовое значение «Да», если нет, то пустое поле.

Прописываем функцию ЕСЛИ с данными параметрами — делаем проверку на то, что выручка больше 50 тыс. руб. ($B5>$C$1), пишем «Да» если выполнено и пустое поле в неприятном случае:

Пример формулы ЕСЛИ с одним условием

Пока смотрится все просто, перейдем к последующему примеру, где уже разглядим не одно, а сходу несколько критерий.

Формула ЕСЛИ с несколькими критериями

Вложенные ЕСЛИ в Excel. Пример 1

Усложним задачку, сейчас найдем таковых служащих, по которым выручка больше 50 тыс. руб. и меньше 70 тыс. руб.

Отчасти эту задачку мы уже сделали в прошлом примере. Вправду, мы отыскали служащих у каких выручка больше 50 тыс. руб., потому на данный момент нам довольно найти лишь тех из их, кто принес меньше 70 тыс. руб.

Также прописываем функцию ЕСЛИ, делаем проверку что выручка больше 50 тыс. руб. ($B5>$D$1), если выполнено, то добавляем еще одну функцию ЕСЛИ где делаем проверку что выручка уже меньше 70 тыс. руб. ($B$5<$D$2).
В случае выполнения всех критерий пишем «Да», в других вариантах оставляем пустое поле:

Вложенные ЕСЛИ пример 1

Как лицезреем количество «Да» у нас сократилось, что разумно потому что мы несколько сузили наше начальное условие по проверке.

Также направьте внимание, что мы реализовали данный пример при помощи вложенного ЕСЛИ, т.е. снутри 1-го ЕСЛИ мы добавили очередной и вроде бы расположили один снутри другого. Давайте попробуем достигнуть такового же результата при помощи внедрения остальных логических функций.

Логическая функция И в Excel

Для альтернативного решения этого примера познакомимся с логической функцией И (AND в британской версии), которая дозволяет проверить одновременную истинность сходу нескольких выражений:

И (логическое_значение1; [логическое_значение2]; [логическое_значение3]; …)

Инспектирует, все ли аргументы имеют значение ИСТИНА, и возвращает значение ИСТИНА, если истинны все аргументы.

Ворачиваясь к нашему примеру нам как раз необходимо проверить одновременное выполнение 2-ух критерий: выручка больше 50 тыс. руб. (условие 1) и выручка меньше 70 тыс. руб. (условие 2).

В итоге оба условия проверяем при помощи функции ЕСЛИ и логического выражения в виде формулы И($B5>$E$1;$B5<$E$2), и возвращаем «Да» в случае правды:

Применение логических функций ЕСЛИ и И

Как лицезреем, в обоих вариантах, как при помощи внедрения вложенного ЕСЛИ, так и при помощи композиции функции ЕСЛИ и функции И, итог вышел схожий.

Вложенные ЕСЛИ в Excel. Пример 2

Предлагаю закрепить материал и решить прямо обратную предшествующему примеру задачку — найдем служащих по которым выручка меньше 50 тыс. руб. (при всем этом давайте в этом случае вернем значение «Плохо) либо больше 70 тыс. руб. (а здесь уже значение «Непревзойденно»).

Также воспользуемся вложенным ЕСЛИ и попеременно проверим несколько критерий, например, поначалу условие на выручку меньше 50 тыс. руб. ($B5<$F$1), в случае истинности возвращаем «Плохо», в других вариантах добавляем еще одну проверку на выручку уже больше 70 тыс. руб. ($B5>$F$2) и пишем значение «Непревзойденно»:

Вложенные ЕСЛИ пример 2

Но мы бы не разбирали этот пример если бы все было так просто

Как и в прошлом примере эту задачку можно испытать решить не только лишь при помощи нескольких вложенных ЕСЛИ, да и остальных логических функций.

Логическая функция ИЛИ в Excel

Как не тяжело додуматься, если мы разобрали функцию И, то где-то рядом непременно будет и иная весьма нужная функция — логическая функция ИЛИ (OR в британской версии), которая дозволяет проверить истинность хотя бы 1-го из выражений (в отличии от И, где проверяется истинность всех значений):

ИЛИ (логическое_значение1; [логическое_значение2]; [логическое_значение3]; …)

Инспектирует, имеет ли хотя бы один из аргументов значение ИСТИНА, и возвращает значение ИСТИНА либо ЛОЖЬ.
Значение ЛОЖЬ ворачивается лишь в этом случае, если все аргументы имеют значение ЛОЖЬ.

Возвращаемся к задачке, в нашем примере обязано производиться одно из 2-ух критерий: или выручка меньше 50 тыс. руб. (условие 1), или больше 70 тыс. руб. (условие 2). Соответственно при помощи функции ЕСЛИ и логического выражения в виде формулы ИЛИ($B5<$G$1;$B5>$G$2) проверяем выполнение критерий, и возвращаем «Да» в случае правды:

Применение логических функций ЕСЛИ и ИЛИ

Итог в целом совпал с предшествующим вариантом, но таковой же вариативности возвращаемых значений, к огорчению, у нас достигнуть уже не получится из-за особенностей функции ИЛИ, т.е. заместо «Плохо» и «Непревзойденно» мы получили лишь 1 вариант ответа «Да».

Потому недочетом таковой реализации является невозможность избрать разные варианты для значения зависимо от выполнения того либо другого условия.

Вообщем далековато не постоянно это необходимо, потому постоянно ориентируйтесь на определенную задачку, которую необходимо выполнить и исходя из этого определяйте лучший вариант пригодный под задачку.

Спасибо за внимание!
Если у вас есть вопросцы и мысли по теме статьи — прошу делиться в комментах.

Как поставить условие в Excel «Если не пусто, то. «

Screenshot_100

Функция в Excel «Если не пусто» — возможность проверить факт наполнения ячейки, чтоб формула не выводила итог при отсутствии значения. Не считая того, можно задать иной параметр, чтоб функция выводила нужные надписи — «Правда» либо «Ересь», «Сдал» либо «На пересдачу», «Продано» либо «В резерве» и т. д. Ниже разглядим индивидуальности данной функции и аспекты ее внедрения.

Как работает условие Excel

Задачка функции Эксель не пустая ячейка либо официально «ЕПУСТО — проверка наличие числа, текста либо формулы. Например, если в ячейке имеется какое-то число, приложение выводит параметр «ЛОЖЬ». Если же в ней что-то стоит, отображается «ИСТИНА». В Эксель функция «ЕПУСТО» является логической, а ее сущность в проверке какого-нибудь условия. По такому же принципу работают и другие функции Excel — «ЕЧИСЛО», «ЕССЫЛКА» и остальные.

Тут производится условие Excel и, если ячейка не пустая, то значение будет «ЛОЖЬ» либо другую надпись. Общее обозначение функции — =ЕПУСТО (значение). Аргумент для данной функции обязателен для наполнения и может иметь вид ссылки на одну либо несколько элеметов таблицы, где необходимо найти какие-либо данные.

Базисные индивидуальности функции для Excel:

  • если в роли аргумента передано какое-то значение, например, «Правда», «Текст» либо «12», результатом выполнения будет ЛОЖЬ;
  • запись с аргументом АДРЕС (x;y)постоянно возвращает ЛОЖЬ, ведь эта функция ведет к ссылке на ячейку либо непустой параметр;
  • по мере необходимости употреблять формулу не пустой ячейки Excel для нескольких граф, можно выделить необходимое число и ввести опцию =ЕПУСТО с аргументом в виде спектра;
  • при желании возврата параметра ИСТИНА, если в секции не пусто, можно добавочно употреблять функцию НЕ.

Как поставить формулу Excel

Сейчас разберемся, как поставить, если не пустое значение ячейки Эксель и употреблять эту опцию. Почти всегда применяется ЕСЛИ и опцию ЕПУСТО. При всем этом полный вид имеет последующий вид — =ЕСЛИ(ЕПУСТО(D2);»Пустая»;»Не пустая»). Тут ЕСЛИ значит, что при пустой D2-ячейке ворачивается текст «Пустая», а если это не так — «Не пустая». Как вариант, можно употреблять какую-то свою подставку (о этом ниже).

Последующий вариант отображения функции Excel, если не пусто, то формула — =ЕСЛИ(D3=»»;»Пустая»;»Не пустая»). Тут в ситуации, если в D3 нет никакого параметра, отображается 1-ая надпись, а в ином случае — 2-ая. В качестве кандидатуры можно употреблять последующий вариант отображения — =ЕСЛИ(D3=»»;»»;ВашаФормула()).

Доп момент

При анализе функции Эксель не равно пусто необходимо осознавать, что функция ЕПУСТО () инспектируют лишь одну графу. Но бывают ситуации, когда нужно проверить сходу несколько. В таком случае применяется функция СЧИТАТЬПУСТОТЫ(). Если в ячейках ничего не содержится, то обозначенная выше функция будет считать даже эти секции вкупе с заполненными.

В ситуации, когда необходимо выяснить, есть ли хотя бы одна незаполненная ячейка в таблице Excel меж В7 и В12, необходимо употреблять формулу = ЕСЛИ(СУММ(—ЕПУСТО(B7:B12));ИСТИНА). Для ответа, имеется ли хотя бы одна заполненная секция в В7 и В12, необходимо создать последующую запись — = НЕ(ЕПУСТО(B7:B12)).

Примеры, когда будет полезна функция в Excel

Эксель формула, если ячейка не пустая, применяется в почти всех вариантах, когда необходимо найти наполнение какой-нибудь графы. Почаще всего это делается для того, чтоб опосля расчета не выдавался итог при отсутствии входного параметра.

Если же гласить о практическом применении в Excel, можно употреблять способ для наполнения таблицы со студентами, которые сдали либо не сдали экзамен. В таковой ведомости будет видно, кто из учащихся совладал с экзаменом, а кто его провалил и отправился на пересдачу. При таком раскладе в столбце выводится строчка «Сдал» около граф, где имеется оценка, либо «На пересдачу» около тех лиц, которые провалили экзамен.

При всем этом формула Excel записывается в последующем формате: =ЕСЛИ(ИЛИ(ЕПУСТО(B4);B3=2);»На пересдачу»;»Сдал»). Тут команда ЕСЛИ инспектирует возвращаемый итог ЕПУСТО для определенного спектра секций. За ранее необходимо выделить секции таблицы, для которых проводится расчет. Результатом выполнения функции является возникновение надписей «Сдал» либо «На пересдачу».

Дальше можно создать форматирование в Excel:

  • Выделите нужные ячейки, а дальше войдите в «Основная» и «Стили». Тут найдите «Условное форматирование» и «Сделать правило».

  • В окне «Создание правила форматирования» изберите функцию «Употреблять формулы для определения …» и введите формулу ИЛИ(ЕПУСТО(В3);В3=2).
  • Нажимайте на «Формат», а опосля укажите в графе «Формат ячеек» красноватый цвет для заливки.
  • Подтвердите действие.

Сейчас в тех ячейках, в каких не заполнено и записано «На пересдачу» происходит заливка красноватым цветом.

Аналогичный принцип можно употреблять и в остальных сферах, например, при прохождении мед осмотра в предприятии, продаже оборудования и т. д. Единственное, что изменяется — значение в колонке Excel, где пусто либо не пусто.

Сейчас вы понимаете, как задается условие Excel, если не пустые либо незаполненные ячейки, как воплотить, и где употреблять эту функцию. В комментах поведайте, понадобились ли для вас приведенные выше советы, и какие еще инструменты можно употреблять.

Интересно почитать:  Как в excel сделать в ячейке выбор из списка
Ссылка на основную публикацию
Adblock
detector