Как сравнить текст в ячейках таблицы Excel

Нередко перед юзерами табличного редактора Эксель стоит таковая задача, как сопоставление текста в ячейках таблички. Существует несколько методов реализации данной нам процедуры. В статье мы детально разглядим любой из методов, позволяющий воплотить сопоставление текстовой инфы в ячейках таблички.

Сопоставление 2-ух ячеек в табличном редакторе

В табличном редакторе имеется два разных способа, позволяющих сравнить текстовую информацию в ячейках. Способы различаются друг от друга тем, что один учитывает регистр, а 2-ой – нет

Применение специальной формулы без учета регистра

Самый простой вариант сопоставления текста в 2-х ячейках без учета регистра – это применение знака «=» меж координатами ячеек. Пример формулы: =А1=В1.

Принципиально! А1 и В1 являются элементами сопоставления. В итоге, в ячейке с формулой выведется или значение ЛОЖЬ, или значение ИСТИНА.

Если юзер хочет в виде результата показать неповторимые сообщения, говорящие о наличие соответствий в ячейках, то добавочно в формулу нужно добавить оператор «ЕСЛИ». Обычный пример таковой формулы: =ЕСЛИ(А2=В2; “Совпадает”; “НЕ совпадает”).

На нижеприведенной картинке отлично видно, как две рассмотренные формулы управляются с процедурой сопоставления текстовой инфы в ячейках.

kak-sravnit-tekst-v-yachejkah-tablicy-excel

1

Применение специальной формулы с учетом регистра

Нередко при работе с документами случаются такие моменты, когда нужно не попросту произвести сопоставление текстовой инфы, да и учитывать регистр. Для реализации данной нам легкой процедуры применятся особый оператор «СОВПАД». В британской варианты он имеет наименование «EXACT». Вид формулы смотрится так: =СОВПАД(текст1; текст2). Аргументы текст1 и текст2 – это координаты ячеек, в которых будет выполняться сопоставление текстовой инфы.

Например, данные для сопоставления размещаются в полях, имеющих координаты А1 и В1. В этом случае, используемая формула будет смотреться так: =СОВПАД(А1; В1). Значение ИСТИНА будет отображено в том случае, если регистр всякого знака будет совпадать. В других вариантах отобразится значение ЛОЖЬ.

Внимание! Если юзер хочет в виде результата показать неповторимые сообщения, говорящие о наличие соответствий в ячейках, то добавочно в формулу нужно добавить оператор «ЕСЛИ».

Обычный пример таковой формулы: =ЕСЛИ(СОВПАД(A1; B1); “Совпадает”; “НЕ совпадает”). На нижеприведенной картинке отлично видно, как две рассмотренные формулы управляются с процедурой сопоставления текстовой инфы в ячейках с учетом регистра.

kak-sravnit-tekst-v-yachejkah-tablicy-excel

2

Сопоставление нескольких ячеек в табличном редакторе

Сейчас побеседуем детально о том, как произвести сопоставление текстовой инфы наиболее, чем в 2-ух ячейках. Эти способы фактически схожи тем, что были рассмотрены выше.

Применение специальной формулы без учета регистра для нескольких ячеек

Тут, как и в ранее рассмотренных способах, применяется две варианты формулы:

  1. 1-ый вариант формулы смотрится так: =И(А1=В1; А1=С1).
  2. 2-ой вариант формулы смотрится так: =ЕСЛИ(И(А1=В1; А1=С1); “Совпадает”; “НЕ совпадает”).

Функция «И» реализует возврат значения ИСТИНА в том случае, если все поля таблички имеют совпадающие значения. Возврат значения ЛОЖЬ происходит, если какое-либо из значений не совпадает. Оператор «ЕСЛИ» дозволяет показать на дисплее те характеристики, которые ввел юзер в формулу.

На нижеприведенной картинке отлично видно, как две рассмотренные формулы управляются с процедурой сопоставления не только лишь текстовой инфы, да и с числовыми показателями, также с данными формата «Дата».

kak-sravnit-tekst-v-yachejkah-tablicy-excel

3

Применение специальной формулы с учетом регистра для нескольких ячеек

Тут, как и в ранее рассмотренных способах, применяется две варианты формулы:

  1. 1-ый вариант формулы смотрится так: =И(СОВПАД(А1;В1); СОВПАД(А1; С2)).
  2. 2-ой вариант формулы смотрится так: =ЕСЛИ(И(СОВПАД(А1;В1);СОВПАД(А1; С1));”Четкое совпадение”; “НЕ совпадает”).

Как и в прошлом примере, функция «И» реализует возврат значения ИСТИНА в том случае, если все поля таблички имеют совпадающие значения. Возврат значения ЛОЖЬ происходит, если какое-либо из значений не совпадает. Оператор «ЕСЛИ» дозволяет показать на дисплее те характеристики, которые ввел юзер в формулу. Итог преобразований смотрится так:

kak-sravnit-tekst-v-yachejkah-tablicy-excel

4

Если юзеру нужно, чтоб формула вывела наличие соответствий хотя бы 2-х характеристик, то ему нужно применять последующую формулу: =ЕСЛИ(ИЛИ(СОВПАД(А1;В1);СОВПАД(А1; С1);СОВПАД(В1;С1)); “Не наименее 2-ух четких соответствий”; “Соответствий нет”). Другими словами, в этом случае наличие хотя бы 2-х соответствий в 3-х вариантах, выведет положительное значение. Итог преобразований смотрится так:

kak-sravnit-tekst-v-yachejkah-tablicy-excel

5

Если же юзеру нужно произвести сопоставление в табличке, в которой находится большущее количество ячеек, то вышеперечисленная формула будет не комфортной в использовании, так как она станет очень длинноватой. Тут целесообразнее применять математический оператор «СЧЕТЕСЛИ». Подсчитать количество соответствий в большенном спектре ячеек можно с помощью последующей формулы: <=СЧЕТЕСЛИ(А2:D2;А2:D2)>. Итог преобразований смотрится так:

kak-sravnit-tekst-v-yachejkah-tablicy-excel

6

Необходимо отметить! Весьма принципиально смотреть за количеством ненадобных пробелов в ячейках. Дело в том, что если в ячейке находится пробел, то он будет восприниматься табличным редактором как знак. Потому перед внедрением формул нужно убедиться в том, что в ячейках отсутствуют ненадобные пробелы.

Заключение

Мы узнали, что в табличном редакторе Эксель существует большущее количество способов, позволяющих воплотить сопоставление текстовой инфы в ячейках. Мы узнали, что можно ассоциировать информацию с учетом регистра и без учета. Для реализации данной нам процедуры потрясающе подступает таковой оператор, как «СОВПАД». Добавочно для наиболее сложных процедур используются такие функции, как «И», «ИЛИ», «ЕСЛИ» И «СЧЕТЕСЛИ».

Как в Эксель сравнить два столбца на совпадения и отыскать расхождения

Screenshot_44

Как в Эксель сравнить два столбца? Напишите в каждой строке интересующих вертикальных секций формулу «ЕСЛИ». Опосля сотворения формулы для 1-й строчки ее можно протянуть / копировать на другие строки. Для проверки содержания схожих строк используйте формулу =ЕСЛИ(A2=B2; “Совпадают”; “”), для различий — =ЕСЛИ(A2<>B2; “Не совпадают”; “”). Ниже тщательно разглядим, как сравнить сведения для 2-ух и наиболее секциях, также побеседуем о выборе результата.

Как сравнить столбцы в Эксель

Одна из особенностей приложения — возможность в Эксель сравнить столбцы (два и наиболее) на факт различий и различий, а опосля вывести результаты в виде подсвечивания цветом. Ниже разглядим, как верно создать эту работу для различного количества столбцов.

При рассмотрении вопросца, как сравнить два столбца в Excel на совпадения / отличия, необходимо сравнить информацию в каждой отдельной строке на отличия и схожие характеристики. Создать таковой шаг можно при помощи «ЕСЛИ». Формула вставляется в каждую строку в примыкающем столбике около таблицы Эксель, где расположены главные характеристики. Опосля сотворения записи для 1-й строчки ее можно протянуть и копировать на остальные строки.

Если вас интересует, как сравнить столбцы в Excel на совпадения, используйте запись с соответственной командой — =ЕСЛИ(A2=B2; “Совпадают”; “”). Бывают ситуации, когда нужно сравнить два столбика и отыскать отличия. В таком случае используйте иную запись — =ЕСЛИ(A2<>B2; “Не совпадают”; “”). По желанию можно выполнить проверку на совпадения / отличия меж 2-мя секциями при помощи одной формулы. Для этого употребляется один из последующих вариантов:

  • =ЕСЛИ(A2=B2; “Совпадают”; “Не совпадают”);
  • =ЕСЛИ(A2<>B2; “Не совпадают”; “Совпадают”).

При всем этом в таблице выводится информация о наличии совпадений либо различий.

Если стоит задачка в Экселе сравнить столбцы с учетом регистра, применяется иная запись. Используйте — =ЕСЛИ(СОВПАД(A2,B2); “Совпадает”; “Неповторимое”)

Другой вариант

Существует очередной метод, как в Эксель сравнить два столбца на совпадения. Задачка в том, чтоб найти повторяющиеся характеристики в обоих столбцах. Тут можно применять упомянутую ранее функцию ЕСЛИ либо СЧЕТЕСЛИ. Формула имеет последующий вид =ЕСЛИ(СЧЁТЕСЛИ($B:$B;$A5)=0; “Нет совпадений в столбце B”; “Есть совпадения в столбце В”). Опосля ввода формулы делается проверка в строке «В» на факт совпадений с данными в строке «А». При наличии фиксированного количества строк в Эксель можно указать определенный спектр, например, $B2:$B20.

Больше 2-ух

По-иному обстоит ситуация, если необходимо сравнить в столбцы в Excel, когда их больше 2-ух. Программка дозволяет ассоциировать данные в нескольких столбиках по ряду критериев: отыскивать строки с схожими значениями во всех либо в 2-ух столбцах. Если их больше 2-ух, используйте функции ЕСЛИ и И. При всем этом сама формула в Эксель приобретает последующий вид — =ЕСЛИ(И(A2=B2;A2=C2); “Совпадают”; ” “). Как программке удалось сравнить данные, в крайней строке выводится информация о совпадении.

Если столбцов в Эксель наиболее 2-ух, рекомендуется применять опцию СЧЕТЕСЛИ и ЕСЛИ. При всем этом сама команда приобретает последующий вид — =ЕСЛИ(СЧЁТЕСЛИ($A2:$C2;$A2)=3;”Совпадают”;” “).

Поиск совпадений в 2-ух и наиболее столбцах

Бывают ситуации, когда в Эксель нужно сравнить несколько столбцов, но отыскать совпадения хотя бы в 2-ух из их. В таком случае используются функции ИЛИ и ЕСЛИ. Для решения задачки делается последующая запись в специальной графе =ЕСЛИ(ИЛИ(A2=B2;B2=C2;A2=C2);”Совпадают”;” “).

В случае, когда в таблице много больше 2-ух столбцов, формула быть может очень большенный, ведь в ней необходимо указывать характеристики совпадения для каждой вертикальной секции таблицы. Чтоб улучшить процесс, необходимо применять другую функцию СЧЕТЕСЛИ. При всем этом полная запись будет иметь последующий вид: =ЕСЛИ(СЧЁТЕСЛИ(B2:D2;A2)+СЧЁТЕСЛИ(C2:D2;B2)+(C2=D2)=0; “Неповторимая строчка”; “Не неповторимая строчка”).

В данной нам формуле условно выделяется две части. В первой СЧЕТЕСЛИ дозволяет высчитать число столбцов в строке с параметром А2 в ячейке, а 2-ая вычисляет это количество в таблице с параметром из В2. При равенстве результата «0» можно гласить, что в каждой ячейке столбца у данной нам сроки находятся неповторимые характеристики. При всем этом формула для Эксель выдает итог «Неповторимая строчка», а при их отсутствии «Не неповторимая …».

Как вывести итог в Эксель

Выше мы уже разглядел, как в Excel сравнить данные для 2-ух либо наиболее столбцов. В обозначенных выше вариантах информация выводится в крайней строке таблицы и указывает, совпадают данные либо различаются в зависимости от задачки и применяемой команды. Но существует очередной путь — выделение совпадений одним цветом в 2-ух и наиболее столбцах. В таком случае информация смотрится наиболее наглядно.

Для этого в Эксель сделайте последующее:

  • Выделите вертикальные секции с данными, которые необходимо сравнить.
  • Войдите во вкладку «Основная» на панели инструментов и нажимайте «Условное форматирование».
  • Кликните на пункт «Правила выделения ячеек» и «Повторяющиеся значения».

  • В показавшемся диалоговом окне изберите слева пункт «Повторяющиеся», а в правом перечне укажите, каким цветом будут выделяться данные. Нажимайте на клавишу «ОК».
  • Опосля этого в выделенной колонке подсвечиваются цветом совпадения.

При желании можно отыскать и выделить совпадающие в Эксель строчки. Для этого сделайте последующее:

  1. С правой стороны от таблицы сделайте доп столбик, где напротив каждой строки с информацией установите формулу. Крайняя обязана соединять воединыжды все характеристики строчки в одну ячейку. В доборной колонке будут видны объединенные сведения.
  2. Выделите область с информацией в доборной колонке.
  3. В разделе «Основная» нажимайте на «Условное форматирование», а опосля «Правила выделения ячеек».
  4. Кликните на «Повторяющиеся значения».
  5. Во всплывающем окне изберите слева в списке «Повторяющиеся», а справа — укажите цвет, который будет употребляться для выделения характеристик.

Если нужно выделить цветом сами строчки в таблице Эксель, также сделайте доп столбик, а в каждой строке используйте формулу =A2&B2&C2&D2. Опосля этого выделите все данные таблицы, войдите в «Основная» и пункт «Условное форматирование». Тут нажимайте на «Сделать правило» и «Создание правила форматирования». Сейчас нажимайте на «Применять формулу для определения…» и в группы «Форматировать значения, для которых …» введите =СЧЁТЕСЛИ($E$2:$E$15;$E2)>1. На завершающе шаге задайте формат отысканных дублей.

Сейчас вы понимаете, как в Эксель сравнить два столбика и наиболее, а опосля вывести результаты цветом либо в крайней колонке. В комментах поделитесь, удалось ли для вас создать работу, и какие еще способы можно применять.

Как сравнить два столбца в Excel на совпадения: 6 методов

Табличный микропроцессор Эксель – одна из самых фаворитных программ для работы с электрическими таблицами. И часто у юзера возникает вопросец – можно ли сравнить в Excel несколько столбцов на наличие совпадений. В особенности это принципиально для тех, кто работает с большими размерами инфы и, соответственно, большенными таблицами.

Как сравнить два столбца в Excel на совпадения: 6 способов

Колонки ассоциируют для того, чтоб, к примеру, в отчетах не было дубликатов. Либо, напротив, для проверки корректности наполнения — с поиском непохожих значений. И проще всего делать сопоставление 2-ух столбцов на совпадение в Excel — для этого есть 6 методов.

1 Сопоставление при помощи обычного поиска

При наличии маленький по размеру таблицы заниматься сопоставлением можно фактически вручную. Для этого довольно выполнить несколько обычных действий.

  1. Перейти на главную вкладку табличного микропроцессора.
  2. В группе «Редактирование» избрать пункт поиска.
  3. Выделить столбец, в котором будет производиться поиск совпадений — к примеру, 2-ой.
  4. Вручную задавать значения из основного столбца (в данном случае — первого) и находить совпадения.

Если значение найдено, результатом станет выделение подходящей ячейки. Но при помощи такового метода можно работать лишь с маленькими столбцами. И, если это просто числа, так можно создать и без поиска — определяя совпадения зрительно. Вообщем, если в колонках записаны огромные объемы текста, даже таковая обычная методика дозволит упростить поиск четкого совпадения.

Как работает округление чисел в Эксель: принципы и настройки

2 Операторы ЕСЛИ и СЧЕТЕСЛИ

Очередной метод сопоставления значений в 2-ух столбцах Excel подступает для таблиц фактически неограниченного размера. Он основан на применении условного оператора ЕСЛИ и различается от остальных методик тем, что для анализа совпадений берется лишь обозначенная в формуле часть, а не все значения массива. Порядок действий при использовании методики тоже не очень непростой и подойдет даже для начинающего юзера Excel.

  1. Сравниваемые столбцы располагаются на одном листе. Не непременно, чтоб они находились рядом вместе.
  2. В 3-ем столбце, к примеру, в ячейке J6, ввести формулу такового типа: =ЕСЛИ(ЕОШИБКА(ПОИСКПОЗ(H6;$I$6:$I$14;0));»;H6)
  3. Протянуть формулу до конца столбца.

Результатом станет возникновение в третьей колонке всех совпадающих значений. При этом H6 в примере — это 1-ая ячейка 1-го из сравниваемых столбцов. А спектр $I$6:$I$14 — все значения 2-ой участвующей в сопоставлении колонки. Функция будет поочередно ассоциировать данные и располагать лишь те из их, которые совпали. Но выделения найденных совпадений не происходит, потому методика подступает далековато не для всех ситуаций.

Очередной метод подразумевает поиск не попросту дубликатов в различных колонках, да и их расположения в границах одной строчки. Для этого можно применить все этот же оператор ЕСЛИ, добавив к нему еще одну функцию Excel — И. Формула поиска дубликатов для данного примера будет последующей: =ЕСЛИ(И(H6=I6); «Совпадают»; «») — ее буквально так же располагают в ячейке J6 и протягивают до самого низа проверяемого спектра. При наличии совпадений покажется обозначенная надпись (можно избрать «Совпадают» либо «Совпадение»), при отсутствии — будет выдаваться пустота.

Этот же метод подойдет и для сопоставления сходу огромного количества колонок с данными на четкое совпадение не только лишь значения, да и строчки. Для этого применяется уже не оператор ЕСЛИ, а функция СЧЕТЕСЛИ. Принцип написания и размещения формулы схожий.

Она имеет вид =ЕСЛИ(СЧЕТЕСЛИ($H6:$J6;$H6)=3; «Совпадают»;») и обязана располагаться в высшей части последующего столбца с протягиванием вниз. Но в формулу добавляется еще количество сравниваемых колонок — в данном случае, три.

Если поставить заместо тройки двойку, результатом будет поиск лишь тех совпадений с первой колонкой, которые находятся в одном из остальных столбцов. При этом, тройные дубликаты формула проигнорирует. Так же как и совпадения 2-ой и третьей колонки.

3 Формула подстановки ВПР

Принцип деяния очередной функции для поиска дубликатов припоминает 1-ый метод внедрением оператора ЕСЛИ. Но заместо ПОИСКПОЗ применяется ВПР, которую можно расшифровать как «Вертикальный Просмотр». Для сопоставления 2-ух столбцов из схожего примера следует ввести в верхнюю ячейку (J6) третьей колонки формулу =ВПР(H6;$I$6:$I$15;1;0) и протянуть ее в самый низ, до J15.

При помощи данной нам функции не попросту просматриваются и сравниваются повторяющиеся данные — результаты проверки инсталлируются верно напротив сравниваемого значения в первом столбце. Если программка не отыскала совпадений, выдается #Н/Д.

4 Функция СОВПАД

Довольно просто выполнить в Эксель сопоставление 2-ух столбцов при помощи еще 2-ух нужных операторов — всераспространенного ИЛИ и встречающейся намного пореже функции СОВПАД. Для ее использования производятся такие деяния:

  1. В 3-ем столбце, где будут располагаться результаты, вводится формула =ИЛИ(СОВПАД(I6;$H$6:$H$19))
  2. Заместо нажатия Enter нажимается композиция кнопок Ctr + Shift + Enter. Результатом станет возникновение фигурных скобок слева и справа формулы.
  3. Формула протягивается вниз, до конца сравниваемой колонки — в данном случае проверяется наличие данных из второго столбца в первом. Это дозволит изменяться сравниваемому показателю, тогда как символ $ закрепляет спектр, с которым производится сопоставление.

Результатом такового сопоставления будет вывод уже не отысканного совпадающего значения, а булевой переменной. В случае нахождения это будет «ИСТИНА». Если ни 1-го совпадения не было найдено — в ячейке покажется надпись «ЛОЖЬ».

Необходимо отметить, что функция СОВПАД ассоциирует и числа, и остальные виды данных с учетом верхнего регистра. А одним из самых всераспространенных методом использования таковой формулы сопоставления 2-ух столбцов в Excel является поиска инфы в базе данных. К примеру, отдельных видов мебели в каталоге.

5 Сопоставление с выделением совпадений цветом

В поисках совпадений меж данными в 2 столбцах юзеру Excel может пригодиться выделить отысканные дубликаты, чтоб их было просто отыскать. Это дозволит упростить поиск ячеек, в которых находятся совпадающие значения. Выделять совпадения и различия можно цветом — для этого пригодится применить условное форматирование.

8 методов как сравнить две таблицы в Excel

Sverit 2 tablici 1 8 способов как сравнить две таблицы в Excel Хороший денек!

Эта статья посвящена решению такового вопросца, как сравнить две таблицы в Excel, ну либо, по последней мере, два столбца. Да, работать с таблицами комфортно и отлично, но вот когда необходимо их сопоставление, зрительно это создать довольно проблемно. Может быть таблицу до 10-ка либо 2-ух, вы и можете зрительно отсортировать, но вот когда они будут превосходить тыщи, здесь уже для вас будет нужно доп инструменты анализа.

Как досадно бы это не звучало, нет волшебной палочки, при помощи которой в один клик всё сделается и информация будет испытана, нужно и приготовить данные, и прописать формулы, и другие процедуры дозволяющие сравнить вашитаблицы.

Разглядим несколько вариантов и способностей для сопоставления таблиц в Excel:

  • обычной метод, как сравнить две таблицы в Excel;
  • резвое выделение значений, которые различаются;
  • сравнить две таблицы в Excel при помощи условного форматирования;
  • сравнить две таблицы в Excel при помощи функции СЧЁТЕСЛИ и правил;
  • как сравнить две таблицы в Excel при помощи функции ВПР;
  • как сравнить две таблицы в Excel при помощи функции ЕСЛИ;
  • сравнить две таблицы при помощи макроса VBA;
  • сравнить при помощи надстройки Inquire.

Обычный метод, как сравнить две таблицы в Excel

Это самые обычной и простый метод сопоставления 2-ух таблиц. Ассоциировать таковым методом может быть, как числовые значение, так и текстовые. Для примера сравним два спектра числовых значений, всего на всего прописав в примыкающей ячейке формулу их равенства =C2=E2, как итог при равенстве ячеек мы получим ответ «ИСТИНА», а если совпадений нет, будет «ЛОЖЬ». Сейчас обычным авто копированием копируем на весь спектр нашу формулу позволяющую сравнить два столбика в Excel и лицезреем разницу.

Sverit 2 tablici 2 8 способов как сравнить две таблицы в Excel

Резвое выделение значений, которые различаются

Это также не весьма обременительный метод. Если для вас просто необходимо отыскать и удостовериться в наличии, ну либо отсутствии различий меж таблицами, для вас необходимо на вкладке «Основная», избрать клавишу меню «Отыскать и выделить», за ранее выделив спектр где нужно сравнить две таблицы в Excel. В открывшимся меню изберите пункт «Выделить группу ячеек…» и в показавшемся диалоговом окне изберите «отличия по строчкам».Sverit 2 tablici 3 8 способов как сравнить две таблицы в ExcelSverit 2 tablici 4 8 способов как сравнить две таблицы в Excel

Сравнить две таблицы в Excel при помощи условного форматирования

Весьма неплохой метод, при котором вы можете созидать выделенным цветом значение, которые при сличении 2-ух таблиц различаются. Применить условное форматирование вы сможете на вкладке «Основная», нажав клавишу «Условное форматирование» и в предоставленном перечне избираем «Управление правилами».Sverit 2 tablici 5 8 способов как сравнить две таблицы в Excel В диалоговом окне «Диспетчер правил условного форматирования», нажимаем кнопку «Сделать правило» и в новеньком диалоговом окне «Создание правила форматирования», избираем правило «Применять формулу для определения форматируемых ячеек». В поле «Поменять описание правила» вводим формулу =$C2<>$E2 для определения ячейки, которое необходимо форматировать, и жмем клавишу «Формат».Sverit 2 tablici 6 8 способов как сравнить две таблицы в Excel Определяем стиль того, как будет форматироваться наше значение, которое соответствует аспекту. Sverit 2 tablici 7 8 способов как сравнить две таблицы в Excel Сейчас в перечне правил возникло наше ново сотворённое правило, вы его выбираете, нажимаете «Ок».

И все правило применилось к нашему спектру, где мы пытаемся проверить на похожесть две таблицы, и сделалось видны отличия, к которым применилось условное форматирование.

Sverit 2 tablici 8 8 способов как сравнить две таблицы в Excel

Как сравнить две таблицы в Excel при помощи функции СЧЁТЕСЛИ и правил

Sverit 2 tablici 9 8 способов как сравнить две таблицы в Excel

Все перечисленные выше методы неплохи для упорядоченных таблиц, а вот когда данные, не упорядоченные нужны другие методы один из которых мы на данный момент и разглядим. Представим, например, у нас есть 2 таблицы, значения в которых незначительно различаются и нам нужно сравнить эти таблицы для определения значения, которое различается. Выделяем значение в спектре первой таблицы и на вкладке «Основная», пункт меню «Условное форматирование» и в перечне нажимаем пункт «Сделать правило…», избираем правило «Применять формулу для определения форматируемых ячеек», вписываем формулу =СЧЁТЕСЛИ($C$1:$C$7;C1)=0 и избираем формат условного форматирования.

Формула инспектирует значение из определенной ячейки C1 и ассоциирует ее с обозначенным спектром $C$1:$C$7 из второго столбика. Копируем правило на весь спектр, в котором мы сравниваем таблицы и получаем выделенные цветом ячейки значения, которых не повторяется.

Как сравнить две таблицы в Excel при помощи функции ВПР

В этом варианте мы будем применять функцию ВПР, которая дозволит нам сравнить две таблицы на предмет совпадений. Для сопоставления 2-ух столбиков, введите формулу =ВПР(C2;$D$2:$D$7;1;0) и скопируйте ее на весь сравниваемый спектр. Эта формула поочередно начинает инспектировать есть ли повторы значения из столбика А в столбике В, ну и соответственно возвращает значение элемента, если оно было там найдено если же значение не найдено получаем ошибку #Н/Д.

Sverit 2 tablici 10 8 способов как сравнить две таблицы в Excel

Как сравнить две таблицы в Excel функции ЕСЛИ

Этот вариант предугадывает использования логической функции ЕСЛИ и отличие этого метода в том что для сопоставления 2-ух столбцов будет применен не весь массив полностью, а лишь та ее часть, которая нужна для сопоставления.

Для примера, сравним два столбика А и В на рабочем листе, в примыкающей колонке С введем формулу: =ЕСЛИ(ЕОШИБКА(ПОИСКПОЗ(C2;$E$2:$E$7;0));»»;C2) и копируем ее на весь вычисляемый спектр. Эта формула дозволяет просматривать поочередно есть ли определенные элементы из обозначенного столбика А в столбике В и возвращает значение, в случае если оно было найдено в столбике В.

Sverit 2 tablici 11 8 способов как сравнить две таблицы в Excel

Сравнить две таблицы при помощи макроса VBA

Есть много методов проверить две таблицы на схожесть, но некие варианты может быть лишь при помощи макросов VBA. Макросы для того что бы сравнить две таблицы, унифицирует этот процесс и значительно уменьшает затраченное время на подготовку данных. Исходя из решаемой вами задачки и познаний макросов VBA, вы сможете создавать любые варианты макросов. Ниже я привел методику, обозначенную на официальной странице Microsoft. Для вас необходимо сделать модуль для кода VBA и ввести код:

Интересно почитать:  Как поменять формат ячейки в excel на числовой
Ссылка на основную публикацию
Adblock
detector