Как в excel посчитать средневзвешенное значение - Учим Эксель

Как в кабинете

Как посчитать средневзвешенное значение в Excel

Excel преобразовал вычисление среднего арифметического нескольких ячеек в весьма ординарную задачку — просто используйте функцию СРЗНАЧ (AVERAGE). Но что созодать, если некие значения имеют больший вес, чем остальные? К примеру, на почти всех курсах испытания имеют больший вес, чем задания. Для таковых случаев нужно рассчитывать среднее взвешенное .

В Excel нет функции для расчёта средневзвешенного значения, зато есть функция, которая сделает за Вас огромную часть работы: СУММПРОИЗВ (SUMPRODUCT). И даже, если Вы никогда не употребляли эту функцию ранее, то к концу данной нам статьи будете работать с ней как профи. Способ, который мы используем, работает в хоть какой версии Excel, также в остальных электрических таблицах, таковых как Гугл Sheets.

Подготавливаем таблицу

Если Вы собираетесь вычислять среднее взвешенное, Для вас будет нужно минимум два столбца. 1-ый столбец (в нашем примере — столбец B) содержит оценки для всякого задания либо теста. 2-ой столбец (столбец C) содержит веса. Больший вес значит большее воздействие задания либо теста на итоговую оценку.

Чтоб осознать, что такое вес, Вы сможете представить его, как процент от итоговой оценки. По сути это не так, так как в таком случае веса в сумме должны составлять 100%. Формула, которую мы разберем в этом уроке, будет подсчитывать все верно и не зависеть от суммы, в которую складываются веса.

Функция СУММПРОИЗВ в Excel

Вводим формулу

Сейчас, когда наша таблица готова, мы добавляем формулу в ячейку B10 (подойдёт неважно какая пустая ячейка). Как и с хоть какой иной формулой в Excel, начинаем со знака равенства (=).

1-ая часть нашей формулы — это функция СУММПРОИЗВ (SUMPRODUCT). Аргументы должны быть заключены в скобки, потому открываем их:

Интересно почитать:  Как в excel присвоить имя диапазону

Чтоб выполнить операцию деления, продолжаем уже введённую формулу эмблемой / (прямой слеш), а дальше записываем функцию СУММ (SUM):

=СУММПРОИЗВ(B2:B9;C2:C9)/СУММ( =SUMPRODUCT(B2:B9, C2:C9)/SUM(

=СУММПРОИЗВ(B2:B9;C2:C9)/СУММ(C2:C9) =SUMPRODUCT(B2:B9, C2:C9)/SUM(C2:C9)

Как это работает

Давайте разберем каждую часть формулы, начиная с функции СУММПРОИЗВ (SUMPRODUCT), чтоб осознать, как она работает. Функция СУММПРОИЗВ (SUMPRODUCT) вычисляет произведение оценки всякого задания на его вес, а потом суммирует все приобретенные произведения. Иными словами, функция находит сумму произведений (sum of the products), отсюда она и получила своё заглавие. Итак, для Задания 1 умножаем 85 на 5, а для Теста умножаем 83 на 25.

Если Вас поражает, для чего перемножать значения в первой части, представьте, что чем больше вес у задания, тем большее число раз мы должны учесть оценку за него. К примеру, Задание 2 посчитано 5 раз, а Итоговый экзамен — 45 раз. Вот почему Итоговый экзамен имеет большее воздействие на итоговую оценку.

Для сопоставления, при вычислении обыденного среднеарифметического, каждое значение учитывается лишь один раз, то все есть значения имеют равный вес.

Сама по для себя функция СУММПРОИЗВ (SUMPRODUCT) возвращает нам большущее число — 10450. В этот момент врубается 2-ая часть формулы: /СУММ(C2:C9) либо /SUM(C2:C9), которая возвращает итог в обычный спектр оценок, давая ответ 83,6.

2-ая часть формулы весьма принципиальна, т.к. дозволяет автоматом корректировать вычисления. Помните, что веса не должны складываться в сумму 100%? Все это благодаря 2-ой части формулы. К примеру, если мы увеличиваем одно либо несколько значений весов, 2-ая часть формулы просто выполнит деление на большее значение, вновь приводя к правильному ответу. Либо же мы можем создать веса намного меньше, к примеру, указать такие значения как 0,5, 2,5, 3 либо 4,5, и формула как и раньше будет работать верно. Здорово, правда?

Ссылка на основную публикацию
Adblock
detector